Comparison result is null even using license


#1

Hi,

I was doing comparison of word documents (.docx format). The program was working but now I’m trying to run it and it is giving me null value for the comparison result. Everything is same as it was before nothing has been changed but it is giving same exception for every document I tested


#2

@muhammad555,

Thank you for your inquiry.

Are you getting this exception for all .docx formatted documents or for all the other supported documents (like .pdf or .xlsx) as well?


#3

@atirtahir3,

I’m getting this exception for .docx and .pdf formats. It was working before and now very strange its not working.
I also tried new update of GroupDocs.comparison v.18.7.0 thinking it can be becuase of new update but got same result.


#4

@muhammad555,

In order to further investigate this issue at our end. We need a simple (console based) project from you using that issue could be reproduced, along-with the problematic files.


#5

@atirtahir3,

I will get back to you once I have that


#6

@muhammad555,

Sure.


#7

@atirtahir3,

I tried it on console based program and it works over there. Don’t know what is wrong in the web based one. I used the same code I wrote in web.


#8

@muhammad555,

In that case, you have to share the web based project with us. Please remove the binaries (e.g. GroupDocs.Comparison for .NET DLL) and the license file from the project that you’ll share.


#9

@atirtahir3,

I’m using aspose APIs for the conversions so if I need to remove them too please tell me.


#10

@atirtahir3,

I have removed the license files and binaries except .DLL for aspose. Can you give me upload link for the project its size is over 100MB and I can’t able to upload it here.


#11

@muhammad555,

Yes, you can remove them and upload again.
We’d recommend you to enable NuGet package restore before sending the project, so that we can restore all missing DLLs on project build.


#12

@atirtahir3,

I looked in the Nuget package manager and that setting was enabled. I’m still can’t able to send the project its size is 34 MB


#13

@muhammad555,

You can upload your project on some cloud storage (e.g. Dropbox) and share link with us.