Free Support Forum - groupdocs.com

Access denied error


#1

Hello, I’ve created a simple .net app (4.5 - webforms) to demonstrate the groupdoc viewer and everything works great.

I’m trying to implement the same code into an existing application (that is under TFS) and everytime I try to view a document, I get an error on the viewer control that says

“An exception of type ‘System.UnauthorizedAccessException’ occurred in mscorlib.dll but was not handled in user code



Additional information: Access to the path ‘temp\S’ is denied.”



The only difference is the existing application is in TFS. I’ve trying giving everyone all permissions and still does not work.

Any suggestions?

Thank you,

Karen


#2

Hi Karen,


Thank you for the request. The issue related to the TFS configurations and security system and have nothing with the Viewer. The only solution from the Viewer side which I can suggest you is to use Url(string url, string userName, string password, string domain) option in the Viewer widget to open the document as described here

Best regards.

#3

I looked at the url you suggested, it seems it’s only for when accessing documents via http?



" This article shows how to load documents when GroupDocs.Viewer is installed on one machine, while the target documents are located on another one and can be loaded only as an HTTP resource via URL"



The documents I am accessing are on another machine, however they are not accessible via a url. I am loading the documents into the viewer by a stream. There is no issue retrieving the stream. The issue is when the code runs in the below:



<%=Viewer.ClientCode().Stream(this.ByteStream, this.Filename, this.Extension, null, false, null)

.TargetElementSelector("#viewer")

.LoadAllPagesOnSearch(true)

.SearchForSeparateWords(true)

.UseHtmlBasedEngine(true).ShowThumbnails(false)

%>


#4

Hi,


Thank you for the clarification. In such case I can assume that the Viewer doesn’t have write access to the folder which you set as root storage to save the cache files. Please grant full read/write access for all users for the root storage folder.

Best regards.