Free Support Forum - groupdocs.com

Auto zooming on two pages in a row and paging not working


#1
I am using Viewer for .Net version(2.14).

The word document is not rendering correctly in html rendering mode.
my issue is not exactly but in some way similar to below issue
http://groupdocs.com/Community/forums/thread/5746/error-parameter-name-embedimagesintohtmlforwordfiles.aspx

Additionally the document(docx file) rendering is also incorrect.
I have used all the guidelines you mention but that doesn't worked out.

despite from this, I have 2 more issue with concern

1. Zooming: Auto zooming to fit the width is not working when switch from one page to "two page in a row" view, Instead of adjusting the zoom level it gives me horizontal scroll bar which is unacceptable.

2. Paging: The current page number is not being shown on the menu bar, Also when we jump through Page number it does not work and throw to first page.
below is the widget setting we currently have

<%=
Viewer.ClientCode()
.TargetElementSelector("")
.Stream(this.fileStream,this.attachmentFileName,this.fileExtention)
.EnableRightClickMenu(true)
.ShowThumbnails(true)
.OpenThumbnails(false)
.ShowPrint(false)
.Height(500)
.Locale("en-US")
.ZoomToFitWidth(true)
.BackgroundColor("#00005C")
.ShowFolderBrowser(false)
.ShowPaging(true)
.ShowDownload(false)
.ShowSearch(true)
.PreloadPagesCount(1)
.UseHtmlBasedEngine(true)
%>

let me know all the possible way to resolve above problems.
Thanks

#2

Hello,


We are sorry to hear that you have such issue. First of all please update your Viewer up to the latest version. Could be that your issues already fixed.

Also we have tested your issues with zooming and paging. The issue with zoom is reproduced and will be fixed - we have created a bug ticket for it.

As for the paging issue - we can reproduce it, as you can see on this screencat paging works fine for us. Since that could you please provide more info for how to reproduce it with screenshots and document example (could be that this issue is document related).

Best regards.

#3

The issues you have found earlier (filed as WEB-2088) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by GroupDocsNotifier.

#4

Hi Pavel,



I was just wondering if this issue has been resolved yet.



Regards


#5

Thanks for working on this.

but the issue is not resolved on my side with your latest Assembly(2.17.0.11270).

would you please look on the above setting and do let me know whether we do need to change something according to new version.
suggest all possible way to fix this.
Thanks


#6

Hello,


Thank you for coming back. “Auto-zooming to fit width” feature is designed to fit the width of the current page to the width of the browser’s viewport. This feature always fit width of a single current page even if a “Two pages in row” or “CoverThenTwoPagesInRow” layout option is used.

Best regards.

#7

Hello,


The latest version of the library is 2.18.0. Please download and try with it.

Best regards.

#8

Hello


Thanks for correcting me.
I have used your new assambly(2.18). this even does not resolve the issue at my end.

although during investigation I have figured out that the using UseHtmlBasedEngine method does not allow the document to render in ‘Double Page Flip’ mode.

we do require to render the document in HTML based rendering mode but without loosing the functionality of Double Page Flip.

Please refer your sample example and use UseHtmlBasedEngine method to replicate the issue.
Suggest a suitable solution for this issue.

#9

Hello,


Sorry for the delay. We have provided extra investigation for this issue and we will extend ZoomToFitWidth option with functional which will re-size the widget to contain both document pages.

As for the Double page flip - this option doesn’t compatible if to use Two pages in row.

Best regards.



#10

Hi Pavel

Thanks for your response.
Please you confirm that the “Double Page Flip” view is not available in HTML rendering mode.
if not, do you have any plans to add this?

Also suggest if we have any other workaround in which we can adjust the zoom when we hit “Two Page in row” option so we can not see the horizontal scroll bar during switching from “One Page in row” to “Two Page in row”(remember dimension for displaying document is fixed.).

Thanks.

#11

Hi,


Yes, I can confirm that the “Double page flip” doesn’t available in the HTML rendering mode. Unfortunately for the current version of the library we provide only bug fixing support because we work on the brand new Viewer and all new features will be added in it. I will share your request about “Double page flip” in the HTML mode with our Product team and they will check if it possible and if yes we will add it to our plans for the new Viewer.

As for the workaround - unfortunately there is no such workaround, but the issue will be fixed very soon and you will get this functional with out any changing on your side.

Best regards.