Free Support Forum - groupdocs.com

Background images are not loaded

Background images are not loaded in GroupDocs.Viewer, when deployed in IIS.



Viewer_header_wrapper doesn’t have background images for “Open File”, “Download”,“Print”,“View Mode”, “Zoom In”, “Zoom Out”, “Zoom Level”, but have everything else and works fine in all the related events.

It works fine in my local system, but not in Website when deployed in IIS


Hi,


I’m sorry to hear that you have such issue. To fix this issue you should add to your Web.config to system.webServer section this code:


or simply set the runAllManagedModulesForAllRequests parameter of “modules” to “true”:


Best regards.

Thanks for the quick reply.


But it didn’t work.
I have my web.config like below in IIS,
It didn’t work either with

<system.webServer>
</system.webServer>

Hi,


Thank you for the Web.config example. I have checked it and all works well for me, all icons are loaded. Please share with me your project example that I can check it and reproduce the issue on my side.

Also I want to notify you that we have released a next generation Viewer library and you should migrate on it because the legacy Viewer (2.x versions) will not be released any more. If you will have any issues with migration - please create a new forum thread and mark it as 3.0 version in the subject.

Best regards.