Free Support Forum - groupdocs.com

C# nor Java seem to work on most of our input files

After creating a minimal test case (basically creating a Converter instance and calling convert method):

C# throws errors such as “GroupDocs.Conversion.Exceptions.GroupDocsConversionException: Object reference not set to an instance of an object”

Java throws errors such as “java.lang.IllegalArgumentException: Cannot insert a node of this type at this location.”

How to diagnose further this internal groupdocs problem?

What’s weird: your online test formular was able to convert some of our files properly. Is there a difference between your online test service and the provided SDKs (20.6 for java and 20.8 for c#)?

@talaw

The online web application is developed using GroupDocs.Conversion for .NET (same API that you are evaluating). However, in order to investigate your issue, we need following details:

  • Sample code or application
  • Sample files

Sure, where could we submit that?

@talaw

You can share all the details/information here. However, if you’ve to share API licence, please do that in a private message.

@talaw

We have logged these issues in our internal issue tracking system with the following IDs:

  • CONVERSIONNET-4162
  • CONVERSIONJAVA-1075

They’ll be now further investigated, and we’ll notify you in case of any update.

We were able to run the C#/.Net prototype on a Windows platform. So it seems the problem is that the provided sdk doesn’t work on Linux with Mono.

FYI: we are very interested into purchasing asap a license but only if we can make it work on our infrastructure (which is linux-based). Could you provide some hint / ETA when this could be resolved?

@talaw

We’re still investigating these issues. You’ll be notified about the outcomes.

Ok, thanks.

Not sure if that’s useful, but our sample doesn’t work either on Linux and MS .NET Core SDK 3.1.108 (instead of mono).

On the other hand, the Java issue seems related to the way javax.imageio is being used internally. We tried also the latest official Oracle JRE 1.8.0 having same error as our initial OpenJDK try.

@talaw

Thank you for the details. We’ll notify you as there’s any update.

@atirtahir3 we have purchased a license and paid support today.

Could please raise the ticket CONVERSIONNET-4162 as a paid support ticket on our account?

@talaw

If you have purchased the paid support, please raise this issue here and it will be escalated with priority.

@talaw

Please use Maven Assembly Plugin for your project instead Maven Compiler Plugin:

         <plugin>
                <artifactId>maven-assembly-plugin</artifactId>
                <executions>
                    <execution>
                        <phase>package</phase>
                        <goals>
                            <goal>single</goal>
                        </goals>
                    </execution>
                </executions>
                <configuration>
                    <archive>
                        <manifest>
                            <mainClass>com.company.package.Main</mainClass>
                            <addDefaultImplementationEntries>true</addDefaultImplementationEntries>
                            <addDefaultSpecificationEntries>true</addDefaultSpecificationEntries>
                        </manifest>
                        <manifestEntries>
                            <Specification-Vendor>company</Specification-Vendor>
                            <Implementation-Vendor>company</Implementation-Vendor>
                        </manifestEntries>
                    </archive>
                    <descriptorRefs>
                        <descriptorRef>jar-with-dependencies</descriptorRef>
                    </descriptorRefs>
                </configuration>
            </plugin>

It’s important to specify and in configuration. Or you can specify vendor in the Manifest file.