Free Support Forum - groupdocs.com

Cannot perform 2d decoding


#1

Hi,


I’m having a problem viewing a TIFF document with compression CCITT T.4 and am wondering if there is a limitation with the viewer to this effect. This is an old document so I would think this is one of the older TIFF formats. Please see attached document which is giving the problem.

I’ve just renamed the file to .zip in order to attach it so please just rename back to .tiff

Thank you.

#2

Hello Ian,

We are sorry to hear that you have this issue. Thank you for providing the sample file. We can confirm that GroupDocs.Viewer cannot open it - an exception “Aspose.Imaging.Exceptions.ImageFormats.TiffImageException: Cannot decode strip 0. Details: Cannot perform 2d decoding. Missing changes from previous row.” is thrown. Development team now is investigating this file, we will notify you in this forum thread when some news will arise.

Sorry for the inconvenience.


#3

Hello Ian,

Our development team has investigated the “FZ1015FIF.tiff” TIFF file, which you have provided. The sample image CCITT T4.tiff is actually damaged, and was probably generated by some software which was interrupted during the image creation process. The software component inside the GroupDocs.Viewer, which handles the images, contains an ability to perform some data recovery. However, this particular sample TIFF file is damaged beyond repair and therefore may not recover any meaningful information.

Thanks.


#4

Hi Denis,


We’re still having this issue with some of our older TIFF files with the above mentioned compression.

I’ve attached a different tiff file that we’re also getting the same error with. Please will you check and advise if there is a work around for this or will this be able to be sorted out on your side?

This file opens windows photo viewer correctly so I can’t see how the file is damaged.

Regards,
Ian

#5

Hello Ian,


Than kyou for the request and new file example. We have checked it and reproduced the issue. We created a bug ticket and our product team will investigate and resolve it. Unfortunately, at the moment we cannot provide you any reliable estimate regarding this issue. However, you will be notified via this thread as soon as it is resolved.

Sorry for inconvenience.

#6

Hi Pavel,


I am just responding to this thread as we are experiencing the same difficulty and would therefore benefit from knowing if/when this would be corrected in a patch.

Thank you,
Troy

#7

Hello Troy,


Thank you for coming back. Currently the issue with the tiff file is generally solved and the tiff file can be viewed. But unfortunately we have some issue with rendering quality . Since that our product team continue work on this issue. If you want, we can share with you Viewer version with current fix and when quality issue will be resolved we will share the Viewer with final fix.

Best regards and sorry for the inconvenience.