Free Support Forum - groupdocs.com

Can't get joomla plugin to work


#1

Hi.

I just started a trial version of groupdocs, but i got some problems with the joomla plugin.
After i installed the plugin on 2.5 ( i did published them) i cant press the button in the articles.
meaning i cant embedding.
gives me this error
Fatal error: Uncaught ApiException: [400]: missing required parameters thrown in /customers/3/c/6/rfkkbh.dk/httpd.www/plugins/editors-xtd/grpdocsviewer/tree_viewer/lib/groupdocs-php/SharedApi.php on line 180


my PHP Version 5.3.27

i did the same on another site i got, which is 3.1 i get this error
Error displaying the error page: Could not find template “isis”.

just by pressing the GD viewer button.



#2
Hi there,

Many thanks for getting in touch. We’re sorry to see that you’ve plugin-related issues.

The mentioned error is the result of unfilled plugin parameters.Please fill the parameter fields and try again.

For more information on how to install and use the Viewer plugin with Joomla, please refer to the following online help :
http://groupdocs.com/docs/display/Viewer/Integrating+the+Plugin+with+Joomla+Using+Default+Method

Also, we request you to use the latest plugin. You may download the latest plugin from the following links:
http://joomlacode.org/gf/project/groupdocs/frs/?action=FrsReleaseBrowse&frs_package_id=6591

Direct link to download package for Joomla 2.5 :
http://joomlacode.org/gf/download/frsrelease/18755/84778/groupdocs-viewer_plugin_package_1.3.5.zip

Kindly get back to us if the error persists, we’ll be glad to help.

Kind regards,
Vipin Thomas, GroupDocs Support

#3

Hi.

okay so i had a long chat with one of your support member, and still can’t getting it to work.

I downloaded the plugin_package_1.3.5.zip
i noticed after removing the old one and installing the new version, it says 1.3.3
look this image http://dinfond.dk/uo/gdversion.png

but that make me get further than last time, now i got this when i press GroupDocs Viewer in an article.
http://dinfond.dk/uo/groupdoc.png

and when i go change to the plugin Editor Button - GroupDocs Viewer and paste my email in GroupDocs Client Login and password.
i get this error when pressing the GroupDocs Viewer in an article
http://dinfond.dk/uo/GD.png

i verified my email , reinstalled it a few times… same errors.


regards.

#4

Hi there,

We’re sorry to see that the issue persists.

I’ll try to answer your query one by one:

Q. I downloaded the plugin_package_1.3.5.zip

i noticed after removing the old one and installing the new version, it says 1.3.3
look this image http://dinfond.dk/uo/gdversion.png

We’ve rechecked this. Yes, some metadata weren’t updated. We will fix this and upload the updated version of v1.3.5 as soon as possible.

Q. but that make me get further than last time, now i got this when i press GroupDocs Viewer in an article. http://dinfond.dk/uo/groupdoc.png

This is OK. If you can see this error message, then it’s sure that you’re using v1.3.5 and you didn’t provide config details in the Editor plugin. You can provide the Client ID and Private Key directly in this GroupDocs Embedder popup window (where you can see the error notification) and then press the Reload link. Your files will be automatically shown under the “Browse & Embed” tab in the GroupDocs Embedder popup window.

Could you please try the above steps and let us know the results?

Q.and when i go change to the plugin Editor Button - GroupDocs Viewer and paste my email in GroupDocs Client Login and password.
i get this error when pressing the GroupDocs Viewer in an article http://dinfond.dk/uo/GD.png
i verified my email , reinstalled it a few times… same errors.

We are sorry to hear that, but we couldn’t reproduce this issue here. Could you please provide your email (login ID) so that we can check whether your account is still under trial period? Also, if you could please provide the OS version you use, that would be really helpful?


Expecting your reply soon.

Many thanks,

Vipin Thomas, GroupDocs Support

#5
and its correct that Client ID is my email and private key is my password?

Thats doesnt change much.


Error.Please check and fill out Login and Password fields in 'Editor Button - GroupDocs Viewer' module Warning: include_once(/customers/3/c/6/rfkkbh.dk/httpd.www/plugins/editors-xtd/grpdocsviewer/tree_viewer/lib/groupdocs-php/ApiClient.php): failed to open stream: No such file or directory in /customers/3/c/6/rfkkbh.dk/httpd.www/plugins/editors-xtd/grpdocsviewer/tree_viewer/treeviewer.php on line 16 Warning: include_once(): Failed opening '/customers/3/c/6/rfkkbh.dk/httpd.www/plugins/editors-xtd/grpdocsviewer/tree_viewer/lib/groupdocs-php/ApiClient.php' for inclusion (include_path='.:/usr/share/php') in /customers/3/c/6/rfkkbh.dk/httpd.www/plugins/editors-xtd/grpdocsviewer/tree_viewer/treeviewer.php on line 16 Fatal error: Interface 'RequestSigner' not found in /customers/3/c/6/rfkkbh.dk/httpd.www/plugins/editors-xtd/grpdocsviewer/tree_viewer/lib/groupdocs-php/GroupDocsRequestSigner.php on line 18

if i go to Upload & Embed and upload a pdf, it will just give me the same error as last time, after it uploaded.
http://dinfond.dk/uo/GD.png

#6

Hi there,

Thanks for the quick response.

No, the Client ID and Private Key are not your login ID and password, but instead it’s the API keys. Please refer to this online help on how to find your client ID and private key:


Please use your respective client ID and private key to the fields and try embedding the document. Please share the result with us.

Also, if you could provide the following details, it would be really helpful for us to verify the issue:
  • Your operating system details
  • Your GroupDocs account user ID (login email)

Thanks for your patience.

Vipin Thomas, GroupDocs Support.

#7

Hi, okay after re-installing it again it now works. And i see you updated it so it says version 1.3.5.


But i have to type the api key every time i’ll embed a new pdf ?

even so, it seems to work, i’ll test it out.

im running windows 7 pro.

using IE and Chrome.


#8

Hi there,

Many thanks for the info. Glad to hear that the issue is resolved.

You don’t have to enter the API keys each time if the Plugin Parameters are configured.

Please refer to Step 3 of “Configuring the Plugin Parameters” in the documentation page:

http://groupdocs.com/docs/display/Viewer/Integrating+the+Plugin+with+Joomla+Using+Default+Method

Please get back to us if you need any help.

Kind regards,
Vipin Thomas, GroupDocs Support