Free Support Forum - groupdocs.com

Changes not reflected in doc. Possible Caching issue


#1

I am trying out the GroupDocs.Viewer for Java 2.2.0 and I have downloaded the sample project. I am working through the ‘spring’ sample project. I am able to set the filePath in the application.properties to a directory on my machine. I ran project in a Tomcat 7 instance and navigated to http://127.0.0.1:8080/document-viewer and was able to see the viewer widget. I clicked on the folder browser and selected an excel (.xlsx) document to view from the directory that was set by filePath parameter. I viewed the document successfully. I opened the document in an MS excel editor and added some text and saved the file. I then restarted my Tomcat server, navigated to http://127.0.0.1:8080/document-viewer, picked the same excel file from the folder browser, viewed it in the viewer, but the changes that I made in the excel document were not reflected in the viewer. It seems to be caching the file and the viewer doesn’t reflect the changes, even though I have both the groupdocs.viewer.useCache and groupdocs.viewer.useBrowserCache set to false. I tried copying the excel file and changing the name and then I could view the excel file and the changes were reflected. Is there a way to get around this issue without having to rename the file?


#2
Hello!

Thank you for the interest in GroupDocs. We are sorry to see that you have such issue. We reproduced it and our developers already work on it and fix will be available in the next release.

Also, if you set the useHtmlBasedEngine parameter to true then the useCache parameter also has to be true. The engine will rebuild cached files if their creation date is older then the document modification date. This is intended functionality that will be fixed and released with the new version. Please, stay tuned.

#3

Thanks, Ihor.


Just FYI: I tried using groupdocs.viewer.useHtmlBasedEngine=false but I was still running into the caching issue. But like you said “The engine will rebuild cached files if their creation date is older then the document modification date.” I just wanted to document that I tried setting the useHtmlBasedEngine property to false.

#4
Thank you, I noted it. By the way, cache rebuilding have to work in both cases. It have to be fixed in the next release.