Free Support Forum -

Demo project for .NET document annotation and viewer APIs


I downloaded the latest code sample GroupDocs.Total-for-NET-MVC, hoping all previous issues raised would have been resolved. But no, instead new problems have come up.

Viewer Demo:
Problem 1: The Viewer is not showing more then 2 pages if i upload a tiff document.
Problem 2: If i change the value of property “htmlMode” from true to false in configuration.yml file i start getting following exception ViewerProblem2.PNG (61.6 KB). I tested with a ,pptx and .tif file.

Annotation Demo:
Problem 1: After adding few annotations when i click on “Save” option i get error “Image loading failed”.
Problem 2: After adding few annotations when i click on “Download Annotated” option i get error “Failed to annotate stream”.
Problem 3: After adding few annotations when i click on “Download Original” option i get error AnnotationProblem3.PNG (48.6 KB)

We bought the licenses so that we will be able to develop an exceptional DMS product using your tools. but till date this has not happened.

I know you people are working hard and have developed a good product line but still because of these issues our purpose is not getting served.

Please help us in giving a perfect solution.


We’re sorry for the inconvenience you are facing. But we cannot reproduce these issues at our end.

We can easily open a complete multi-paged tiff document - multitif (347.9 KB).

We tested this case with both tif and pptx - htmlmode false - pptx.JPG (99.1 KB). This is not reproduced as well.

We cannot reproduce this issue as well. See this screenshot - save annotation.JPG (62.8 KB). Can you please share the problematic file with us?

We can successfully download the annotated file - download annotated.JPG (147.0 KB)
and original file - download original.JPG (143.6 KB).

Please make sure that you have a valid license and it is properly applied (you must not be getting any evaluation mark in the rendered file). However, in order to further investigate this we need following details:

  • Files you used to reproduce the issue
  • Share any changes if you committed in the project

First time when i ran the application after downloading the project my license file was missing. After placing the right license file still i was getting these errors. But today after deleting all the temp folders in “DocumentSamples” folder the “Viewer” related issues went away. Maybe some temp files were causing problem which where generated when license file was missing.

But i am still facing issues related to annotations. Still after adding few annotations if i try to save or if i try to download annotated file i get errors only in case of tiff file. i tried with a “.pptx” file and it worked. I am testing with (1.5 MB). In my configuration.yml file only i have changed “htmlMode: false” in viewer section.

Also i noticed that in annotation viewer. In my configuration.yml file when i change “preloadPageCount” in annotation section from 0 to 1 then other pages of my test files didn’t get loaded. Only 1st page got rendered and was showing “Loading …” for other pages but never got loaded.


Good to know that.

This issue is reproduced at our end. Hence, we’ve logged it in GitHub. Please follow this link for further correspondence. We’ll also update you here as we have any further update.

We cannot reproduce this issue using the TIFF you shared. Is there any step that we are missing. Can you please share complete details to reproduce this issue.


This problem is there and i have checked multiple times. I am testing with the tiff file which i have shared earlier. In my configuration.yml file i have made following changes.

  1. In viewer section
    htmlMode: true to false
    preloadPageCount: 0 to 1
  2. In annotation section
    preloadPageCount: 0 to 1

After i select the tiff file using browse option it show the 1st page correctly, and on rest of pages it shows like “Loading…Please wait” preloadPageCountIssue1.PNG (24.1 KB)
. After waiting for some time the loading message was gone but the pages where not rendered preloadPageCountIssue2.PNG (35.3 KB)
. I could only see the 1st page and rest of the pages are blank.



This issue is now reproduced at our end. We’ve logged it in GitHub. Please follow this link for further correspondence. We’ll also notify you as we have any further update.


You can now load all pages by setting preloadPageCount to 1 instead of 0. Please pull/download latest release of the showcase project.