Free Support Forum - groupdocs.com

Document to implement Groupdocs.Signature functionality is not updated


#1

Hello,


I am trying to implement Groupdocs.Signature in mvc application with the help of steps provided in below link.

http://groupdocs.com/docs/display/signaturenet/How+to+use+GroupDocs.Signature+for+.NET+in+an+ASP.NET+MVC+Project

but the steps in above link does not match to the example i received from “http://groupdocs.com/Community/files/8/.net-libraries/groupdocs_signature_for_.net/category1007.aspx”. which is quite confusing, and also i am getting errors if i try to follow the documentation link.

can you please let me know where can i find a document which matches to the example?

#2

Hi,


Thank you for your request. We have several MVC example projects which shows how to use the library in different workflows, in the documentation we have description for common (basic) usage. Since that could you please specify which exactly example project you use and what error you get.

Thank you.

#3

Hi,


Thanks for reply.

I downloaded example “GroupDocs.Signature for .NET” listed on below link.

http://groupdocs.com/Community/files/8/.net-libraries/groupdocs_signature_for_.net/category1007.aspx

but when i am trying to implement that example in my application it gives error of "object reference"
and the url of the application becomes “http://localhost/TestSignatureApp/gd-signature/signature2/resource?action=Index&Controller=Home” instead of “http://localhost/TestSignatureApp/Home/Index”.

I have several routes defined in my RouteConfig.cs file. I even tried running the app by removing other routes but no success.




#4

Hi again,


Unfortunately from your post is not clear how to reproduce the issue. Could you please share with me example of your project.

Thank you.

#5

I installed groupdocs.signature package version 1.11.0 from nuget. and initialized it in global.asax by writing below code:


GroupdocsSignature.Init(new GroupdocsSignatureSettings
{
RootStoragePath = Server.MapPath("~/App_Data/"),
DatabaseProvider = new MsSqlProvder(System.Configuration.ConfigurationManager.ConnectionStrings[“SignatureDb”].ConnectionString)
});

But when i run my application, as soon as i press login button, it gives “Object Reference” error in elmah and the application url looks like “http://localhost:49686/gd-signature/signature2/resource?action=Index&controller=Login” now i don’t understand why my application url is getting changed to gd-signature when i am just login into the application.

I hope above information helps. please let me know if you need more information.

#6

Hi,


Thank you for the example. Could you please share with me the full project that you use and I will check and fix it for you.

Thank you.