Free Support Forum - groupdocs.com

Document viewer API missing classes in .NET

Hi,
Trying to update GroupDocs version from 3.7.0 to 17.11.0 in our .Net application through Nuget package. Although package is installed successfully but getting errors for classes like FileDataOptions, WordsFileData, ContentControl. Can you please suggest what could be wrong? Although earlier these classes were present under GroupDocs.Viewer.Converter.Options, GroupDocs.Viewer.Domain namespaces.
Thanks

1 Like

@vijendra.kurmi2014,

We’d recommend you to migrate to the latest release of the API 20.3. Viewer class introduced as a single entry point to manage the document rendering process to any supported file format. Have a look at the migration notes.
We have an updated example project here on GitHub. Please explore this project and share your feedback.

Hi,
Does it mean that we have to rewrite the code which we had earlier if we want to upgrade the version?

Thanks

1 Like

@vijendra.kurmi2014,

As you are using 3.7.0, it’s a quite old version of the API. With the passage of time we keep introducing enhancements/improvements and new features in the API. Eventually, new classes and methods are implemented and old classes/methods become obsolete.
You have to follow the release notes in order to see all the API and backward incompatible changes. However, our GitHub example project is totally updated as per latest version of the API.

So, yes you have to follow the release notes and have to upgrade your code accordingly.

Hi,
We tried to upgrade to version GroupDocs.Viewer 19.4.0 but the error which we thought could be fixed with version upgrade is still there. While viewing most of the excels which have pivot tables we are getting error " The row index should not be inside the pivottable report". We thought this could be fixed if we upgrade the GroupDocs version but still same error. Can you please help us to identify in which scenarios this error occurs.
Thanks

@vijendra.kurmi2014,

Please share the problematic Excel file, exception details/stack trace with us and we’ll investigate this issue.

Hi,

Cannot share excel file but attached is the error stack trace if it helps.GroupDocs_Error.png (243.0 KB)

1 Like

One more query do we need to get different license for different version of GroupDocs?

1 Like

@vijendra.kurmi2014,

In order to investigate this scenario. We need the problematic files. You can share them in a private message. Please don’t worry about the documents confidentiality. Have a look at our privacy policy. If you are not able to upload the files due to size issue, upload them to some cloud storage (e.g. Google Drive) and share link with us in a private message.

Please check your license expiry date and if it’s greater than the release date of the API version that you are using then license will work. Otherwise, you have to renew your license. For example, your license subscription expiry date is 12/12/2019 and the release date of the API version that you are going to use is 15/12/2019, license will not work.