We're sorry GroupDocs doesn't work properply without JavaScript enabled.

Free Support Forum - groupdocs.com

Feature not working on Image and video search

Search isnt working for Image formats and video format
Code:
using GroupDocs.Search;
using GroupDocs.Search.Results;
using System;
using Index = GroupDocs.Search.Index;
//initialize License
License lic = new License();

//Set license
lic.SetLicense(“GroupDocs.Search.NET.lic”);

string indexFolder = @“c:\MyIndex”;
string documentsFolder = @“e:\newfolder”; // NOTE: Put here actual path for your documents
string query = @“socio”;

Index index = new Index(indexFolder); // Creating index in the specified folder
index.Add(documentsFolder); // Indexing documents from the specified folder

SearchResult result = index.Search(query); // Searching in index
foreach (FoundDocument document in result)
{
Console.WriteLine(document.DocumentInfo.FilePath);
}

Files:

aaa.jpg (3.7 KB)
sawq.png (1.3 KB)
Untitled.png (1.8 KB)
.dsd.gif (2.2 KB)
sawq.png (1.3 KB)
Untitled.png (1.8 KB)
aaa.jpg (3.7 KB)

sample.zip (61.5 KB)
Even these files arent workin for any of the text present inside. Interested in your product please Review these things quickly.

@Shahkarhassan

We are investigating this scenario. Your investigation ticket ID is SEARCHNET-2651.
Could you please also share your development environment details?

  • GroupDocs.Search API version (e.g. 21.1, 20.10)
  • .NET Framework (e.g. .NET5. ,NET6)

Could you please also share such images and videos?

Api version : 21.8.1
.Net framework NET 5

images are shared above. they are attached. Couldnt upload video but if the problem is solved for images i guess that will also solve for video.

1 Like

@Shahkarhassan

Text in images is recognized and indexed when you implement or integrate an external library or service for OCR. Please have a look at this documentation article. You can download this example application as well.
However, there is indexing error/issue with document “sample.eml”. We are investigating the problem.

I tried to implement with the same code you gave and it is giving PARAMETER IS NOT VALID in aspose.ocr . Someone else also had this issue but that is private thread and i can’t see the solution to it. Can you please Help me in this? Timeout is happening as “null” value is coming in memory stream. Code is same as yours and directory contains all type of files. Be it text and also png gif. or does it only work when there are ONLY image files? REsult is coming “” for images. Images which i sent above. I have OCR license too

1 Like

@Shahkarhassan

Could you please share the sample application along-with index and documents folder (not just the code file)? We’ll then further look into this issue.

We have not yet implemented text recognition in videos. For video formats, only metadata is indexed.
Also, for the MPP format, only metadata is indexed in accordance with the table.

1 Like

newfolder.zip (627.3 KB)

There is the code file and the document file. Tried both. Tesseract ocr and Aspose ocr. even these images are not detecting “sa” text even on live demo you have implemented on site.

@Shahkarhassan

We are further investigating this issue. Your investigation ticket ID is SEARCHNET-2652. We’ll notify you in case of any update.

1 Like