Free Support Forum - groupdocs.com

Global document access rights not working


#1

Hi,



I use GroupDocs.Annotation for .NET 2.1.1 - thanks for the quick fixes by the way!

If I add .AccessRights(AnnotationReviewerRights.None) to the annotation widget in the Groupdocs.Demo.Annotation.CustomGUI project of your examples I can still annotate, export, move annotations, …



Same behavior with:

ObjectFactory.GetInstance().SetDocumentAccessRights(FileID, AnnotationReviewerRights.None);



Only the collaborator rights (set by ObjectFactory.GetInstance().SetCollaboratorRights(FileID, UserName, rights)) will disallow actions.



I’d expect the access rights to be the intersection of the document and the collaborator rights.



By the way, the documentation could be a bit more precisely:

http://groupdocs.com/docs/display/annotationnet/AnnotationWidgetOptions+AccessRights+Property


#2

Hello,


Thank you for the request. I will investigate this behavior and will discuss it with the Product team and then come back to you with the details.

Best regards.

#3

Hi,


I have investigated the issue and here what I have found:
1. .AccessRights (Annotation ReviewerRights.None) - establishes general rules (for anonymous users).
2. In the example project we have user with rights from the beginning - since that the AccessRights doesn’t have any effect on him
3. To check it you can use new user - for example open Annotation with such URL http://localhost:65271/?un=NewUserName
Then n the DocumentOpenSubscriber.cs replace
svc.Add Collaborator (path, un, null, null, null);
with
svc.AddCollaborator (path, un, null, null, null, AnnotationReviewerRights.None);
to create a collaborator with the rights.

4. SetCollaboratorRights disallow actions because you set the user name.

Summarize all these - to set correctly user rgihts you should use user name and if you need to disallow annotating for anonymous users you should set svc.AddCollaborator (path, “Anonymous”, null, null, null, AnnotationReviewerRights.None);

Best regards.

#4

Hi Pavel,



thanks for this info!

I managed to set the right user rights for our scenario.



But when I only set the user right “AnnotationReviewerRights.CanView” I still can move around annotations. After that this message pops up: “Error - This reviewer does not have enough permissions to perform the operation.” and the changes are discarded after reload.



With the CanView right I’d expect the annotations to be fixed. Allowing temporary modifications with an error message that you have no right to do that is an unusual behavior.



A ViewOnly flag would be nice with no modifications allowed.


#5

Hi,


Glad to hear that you deal with it. Yes, correct you can move around annotations but as you have noticed your changes will not be saved and nobody (if somebody will collaborate same document at the same time) will see these changes. Since that we can say that the changes are not allowed (they will not be saved).

Best regards.

#6

I could live with it, if there was a way to localize the error message in German.

Can this be done somehow?


#7

Hi,


I have created ticket for this. Unfortunately I can’t guarantee that it will be ready very soon but Product team will make such localization.

Best regards.

#8

Hi Pavel,



thanks! There are many other localization issues like the initial “Loading your content…” message.

It would be great if all labels/tooltips/messages could be localized by a Visual Studio resx dictionary.

So the localization can be done by our own.




#9

Hi,


Please fill attached document with translations and we will add German localisation.

Best regards.

#10

Hi,



thanks, but meanwhile I was able to workaround the localization issue.



Coming back to my post from 12-23-2015, 8:29 PM:

The TextFieldAnnotation also is editable with AnnotationReviewerRights.CanView and should be readonly in this mode.



Regards,



Phil


#11

Hi Phil,


Glad to hear that you was able to workaround the localization issue.

As for the user rights - I will check it with our Product team.

Best regards.