Free Support Forum - groupdocs.com

Google.Apis.Oauth2.v2 could not be found


#1

Hello,

I’m using Viewer and Annotation in my web form project. I’m using viewer version “2.12.0.25626”. When i try to open a document it gives error(I added log file as attachment). If i remove viewer’s handlers in web.config viewer doesnt work so it doesnt give this error. It works fine in my developer machine, my two virtual machine but in my colleague’s computer it gives that error.

What can cause it do you think? I downloaded Google.Apis.Oauth2.v2 latest version from nuget because i couldn’t find exact this “1.1.4408.30960” version.

For finding this log file i use fuslogvw.exe. First i run my project without viewer’s handlers and after that i run it with handlers. This log is different only.


#2

Hello again,


After trying lots of things, finally i found something.

I added my web.config as attachment. We using viewer and annatotion together. In the web config there is a module, “AllowCrossOriginModule”. If i remove it those computer that i mention in first message dont gives error anymore. Because we dont use crossorigin. Viewer and our project will work in same server.

After that i delete that module from my developer machine and it gives error(error2.png). I tried it my coleagues dev machine too and it gives different error(error.png).

If i add that module, some servers gives error, if i remove others gives error. I’m stuct. Do you have any idea?

#3
Hello ,

Thank you for your posting and using GroupDocs.

We are trying to reproduce the issue on our side , but we can't reproduce it yet. Seems that we need additional details of your project. Please describe, how you tried to run your project, may be you used IIS server, or standard server from Visual Studio. If you used Visual Studio, then please specify its version and if you used IIS server then specify in which mode ( Classic or Integrated ).

Also we have changed your web.config file and have attached to this thread. Please try to test your project with this updated config file.

------

Best regards,
Evgen Efimov

http://groupdocs.com
Your Document Collaboration APIs
Follow us on LinkedIn, Twitter, Facebook and Google+


#4

Hello,


I tried your web.config too. It works on my dev machine but doesnt work on my test virtual machine. My both machine’s os windows 8.1 and using IIS 8 (exact version 8.5.9600.16384). App pool in both machines are .Net 4.0 integrated.

In your web.config you removed system.web.httphandlers, iis7 and later dont use them you right but we add it for our costemers who doesn’t use ii7 or later.

After you said iis can cause it, i tought so too and i added all features of iis in my test machine but it didnt help too(also i restarted virtual machine for upgrades completely applied to be sure).

#5
Hello,

Please try to add these libraries to your app (https://www.dropbox.com/s/n2bvht4lfibepd5/libs.zip?dl=0), I think these libraries should help you.

------

Best regards,
Evgen Efimov

http://groupdocs.com
Your Document Collaboration APIs
Follow us on LinkedIn, Twitter, Facebook and Google+


#6

Hello,

I tried it, i added to our project but unfortunately it didnt help. I checked the bindings errors with fuslogwm.exe it still same google.apis is the only different log between working(Groupdocs.Web.UI.HttpModules.AllowCrossOriginModule removed) and not working one in the same machine(my test virtual machine)


#7

Hello,


In such case could you please share with us your project example. We will investigate it and will try to reproduce the issue on our side.

------

Best regards,

Evgen Efimov


http://groupdocs.com
Your Document Collaboration APIs
Follow us on LinkedIn, Twitter, Facebook and Google+


#8

Hello again,

After a lots of tries we figured it out why its happening.

First of all we dont have to use “AllowCrossOriginModule” so i removed it from handlers in web.config. Then my dev machine starts to give manifest error when i try to load our project. I use FUSLOGVW.exe again and check all logs carefully. Finally i found out it because of Aspose.Pdf dll version. We also use aspose dlls in our project too. But our pdf dll was little bit older than yours. Than i upgrade it and it worked.

Last thing, i cant open word documents. Viewer was throwing object not refference error. I delete our aspose.word dll then it worked. I can open words documents after that.

Thanks for your all helps. I really appreciate. But i need one more thing. Could you please send me your all of yours aspose dlls versions. We’ll upgrade them exact version, so our project and viewer can work better together.

Best regards,


#9
Hello ,

We are glad to know that your issue was resolved. Sorry, but we don't distribute the Aspose libraries . You can download them on they official site. But if you need the versions of the Aspose libraries that are used by our library, then we can share these versions with you.

-------

Best regards,
Evgen Efimov

http://groupdocs.com
Your Document Collaboration APIs
Follow us on LinkedIn, Twitter, Facebook and Google+


#10

Hello,


Yes, i mean versions. I forgot the write version, after posting i edited my message. I need only versions.

#11
Hello ,

Our GroupDocs.Viewer for .NET library 2.12.0 is using next Aspose libraries:

Aspose.BarCode - 5.8.0.0
Aspose.Cells - 8.4.2.0
Aspose.Diagram - 5.3.0.0
Aspose.Email - 5.2.0.0
Aspose.Imaging - 2.9.0.0
Aspose.Pdf - 10.4.0.0
Aspose.Slides - 15.4.0.0
Aspose.Tasks - 7.0.0.0
Aspose.Words -15.4.0.0

But if you need the versions of Aspose libraries for our new release of the GroupDocs.Viewer for .NET 2.14.0, then please notify us and we will be glad to share them with you.

------

Best regards,
Evgen Efimov

http://groupdocs.com
Your Document Collaboration APIs
Follow us on LinkedIn, Twitter, Facebook and Google+


#12

Hello,

Thank you for the information. When we upgrade .Net Viewer i’ll notify you.

Kind Regards,


#13

Hello,


Thank you for the notification. Sure we will wait for the updates from you.

Best regards.