Free Support Forum - groupdocs.com

Groupdocs-spring-doc-viewer sample doesn't have anything under assets folder


#1

Hi,
I am evaluating document viewer for java.
I downloaded source code for groupdocs-spring-doc-viewer and tried to build and run.
I am unable to open it in browser. Looks like there is no content available under groupdocs-spring-doc-viewer\src\main\resources\static\assets. Due to this I am unable to open the application in the browser. Please help.


#2

@nirajsingh24,

Thanks for posting your inquiry.

We have introduced package management using npm for the frontend components in the latest version of the application. The following is the quickest way to restore all the resources:

  1. Run cd path/to/project/directory
  2. Run mvn install

Hope it helps.


#3

Thanks for the quick response.

I figured out the problem was that I had commented out executions tag from pom as it was giving me some error.

To get this working I ran npm install, and gulp build manually.
After that it got all the resources and started working.

Thanks


#4

@nirajsingh24,

It’s good to know that your issue has been resolved.