Free Support Forum - groupdocs.com

Groupdocs.Viewer for Java 3.0


#1

Hi ,
We have downloaded the latest jar from GroupDocs.Viewer.jar.
On executing getting the below error
D:\doccept\preview\GroupDocs.Viewer_2.14.0-Java-Examples\samples\dropwizard>cd D
:\doccept\preview\GroupDocs.Viewer_3.0.0-Java\lib
D:\doccept\preview\GroupDocs.Viewer_3.0.0-Java\lib>install_library.bat
Installing GroupDocs.Viewer v3.0.0 …
[INFO] Scanning for projects…
[INFO]
[INFO] ------------------------------------------------------------------------
[INFO] Building Maven Stub Project (No POM) 1
[INFO] ------------------------------------------------------------------------
[INFO]
[INFO] — maven-install-plugin:2.4:install-file (default-cli) @ standalone-pom

[INFO] Installing D:\doccept\preview\GroupDocs.Viewer_3.0.0-Java\lib\GroupDocs.V
iewer.jar to C:\Users\sivagu.m2\repository\com\groupdocs\groupdocs-viewer\3.0.0
\groupdocs-viewer-3.0.0.jar
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1.211 s
[INFO] Finished at: 2016-05-24T17:21:53+05:30
[INFO] Final Memory: 6M/122M
[INFO] ------------------------------------------------------------------------
Press any key to continue . . .
D:\doccept\preview\GroupDocs.Viewer_3.0.0-Java\lib>java -jar GroupDocs.Viewer.ja
r
no main manifest attribute, in GroupDocs.Viewer.jar


#2

Hi Jhansim,


Thanks for showing your interest in GroupDocs.Viewer for Java 3.0.0.

I would like to know about your development environment, which Editor you are using and its version (e:g Eclipse Mars.2 Release 4.5.2)?
What is the version of Java framework that you have installed?

Best wishes

#3

Hi,

We are not using IDE , executing the Jar file from Command Prompt using the steps mentioned in my earlier post

Java Version is 1.7

Let us know if you need more details


#4

Hi Jhansim,


Thank you for your explanation.

In fact we couldn’t understand your scenario. Please provide us more details about your case. Are you trying to install API (GroupDocs-viewer-3.0.0.jar) in JDK ?

Best Wishes

#5

Hi ,
The readme is not updated with the steps to execute the Jar file . You can go through the steps that we tried to execute and let us know if we are missing something. Else provide us the steps to test the preview functionality on an IDE or from command prompt.

We are trying to execute using the below steps.

1. Extracted both zip files

<span style=“font-size:12.0pt;font-family:“Times New Roman”,“serif”;mso-fareast-font-family:
“Times New Roman”;color:black;mso-ansi-language:EN-US;mso-fareast-language:
EN-US;mso-bidi-language:AR-SA”>2. Execute the GroupDocs.Viewer-javadoc.jar and
GroupDocs.Viewer.jar files using cmd prompt

<span style=“font-size:12.0pt;font-family:“Times New Roman”,“serif”;mso-fareast-font-family:
“Times New Roman”;color:black;mso-ansi-language:EN-US;mso-fareast-language:
EN-US;mso-bidi-language:AR-SA”>

<span style=“font-size:12.0pt;font-family:“Times New Roman”,“serif”;
mso-fareast-font-family:“Times New Roman”;color:#33CCFF;mso-ansi-language:EN-US;
mso-fareast-language:EN-US;mso-bidi-language:AR-SA”>GroupDocs.Viewer.jar:<span style=“font-size:12.0pt;font-family:“Times New Roman”,“serif”;mso-fareast-font-family:
“Times New Roman”;color:black;mso-ansi-language:EN-US;mso-fareast-language:
EN-US;mso-bidi-language:AR-SA”> Goto command prompt and execute the below command


D:\doccept\preview\GroupDocs.Viewer_3.0.0-Java\lib>java -jar
GroupDocs.Viewer.jar

no main manifest attribute, in GroupDocs.Viewer.jar







<!–[if gte mso 9]>
<w:WordDocument>
<w:View>Normal</w:View>
<w:Zoom>0</w:Zoom>
<w:TrackMoves/>
<w:TrackFormatting/>
<w:PunctuationKerning/>
<w:ValidateAgainstSchemas/>
<w:SaveIfXMLInvalid>false</w:SaveIfXMLInvalid>
<w:IgnoreMixedContent>false</w:IgnoreMixedContent>
<w:AlwaysShowPlaceholderText>false</w:AlwaysShowPlaceholderText>
<w:DoNotPromoteQF/>
<w:LidThemeOther>EN-US</w:LidThemeOther>
<w:LidThemeAsian>X-NONE</w:LidThemeAsian>
<w:LidThemeComplexScript>X-NONE</w:LidThemeComplexScript>
<w:Compatibility>
<w:BreakWrappedTables/>
<w:SnapToGridInCell/>
<w:WrapTextWithPunct/>
<w:UseAsianBreakRules/>
<w:DontGrowAutofit/>
<w:SplitPgBreakAndParaMark/>
<w:EnableOpenTypeKerning/>
<w:DontFlipMirrorIndents/>
<w:OverrideTableStyleHps/>
</w:Compatibility>
<m:mathPr>
<m:mathFont m:val=“Cambria Math”/>
<m:brkBin m:val=“before”/>
<m:brkBinSub m:val="–"/>
<m:smallFrac m:val=“off”/>
<m:dispDef/>
<m:lMargin m:val=“0”/>
<m:rMargin m:val=“0”/>
<m:defJc m:val=“centerGroup”/>
<m:wrapIndent m:val=“1440”/>
<m:intLim m:val=“subSup”/>
<m:naryLim m:val=“undOvr”/>
</m:mathPr></w:WordDocument>
<![endif]–><!–[if gte mso 10]>

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman","serif";}

<![endif]–>


#6

Hi Jhansim,


Thanks for pointing this out.

We have now updated the steps on Wiki, you can followup the updated instructions.
And please make sure that Maven is already installed on your system.

I hope updated steps will resolve your issue.

Best wishes

#7

Hi ,

We want to evaluate groupdocs ( test if preview works for our documents) so can you give us an executable Jar file . The steps you provided are for integrating with API’s which will take time to integrate with our product .

We only need an executable JAR file to test preview functionality. hope you understand what we are asking . Do you have a skype id so that i can call you and explain as this is taking long


#8

Hi Jhanism,


Thank you for your explanation,

Actually, next generation GroupDocs.Viewer for Java 3.x is a UI Less+Backend API. The front end/UI has been disintegrated in this version. Hence, now the users are free to write there own front-ends. They can use GroupDocs.Viewer for Java UI Less API flexibly to write their own viewer.

However, we have also published an open sourced front-end sample project at Github. You can use this sample project for testing/evaluation purpose.

Please let us know if you have any more questions.

Warm Regards

#9

Hi ,
We have integrated with the Document viewer and the view is not coming properly . I have attached the original file and the preview that is coming after integrating with groupdocs.

Can we have a call with your technical team to understand if we are missing something .

This whole process of integration is taking really long and request your help to expedite



#10

Hi Jhanism,


We are unable to reproduce the issue on both Google Chrome and Internet Explorer (Version 9, 10, 8, edge).
Can you please explain the steps you followed to run the project, and also which browser and OS version you are using?

Thanks

#11

Hi ,

We are using windows and browser is Chrome .
Downloaded the sample code shared on wiki link and tried to upload the document attached in the previous mail.

Can we have a call where we show the steps that we followed so that you understand better


#12

Hi Jhansim,


We apologize, we are unable to reproduce your issue at our end. We have tested the file you provided with the same environment and got no issue.
I am sharing the results with you in the form of screenshots.
Please make sure that you are cloning/downloading the examples from here.

Kind regards