Free Support Forum - groupdocs.com

GroupDocs.Viewer Java Library 2.11.0 or 2.9.0 Dependency Artifact Issues when integrating with Maven

Hi,

I am facing Dependency Artifact Issues when i am integrating GroupDocs.Viewer 2.11.0 dependency in my application pom.xml.

Below are the steps i have done.

Downloaded the library from the download archive.
Open console and cd to lib directory.

Run command mvn install:install-file -Dpackaging=jar -Dversion=2.11.0 -DgroupId=com.groupdocs -DartifactId=groupdocs-viewer -Dfile=GroupDocs.Viewer.jar to install library in maven

Then added the below dependency in my pom.xml

com.groupdocs
groupdocs-viewer
2.11.0
jar

But my pom.xml is showing this issue and unable to continue

Multiple annotations found at this line:
- Missing artifact com.aspose:aspose-email:jar:
5.2.0.0
- Missing artifact com.aspose:aspose-
diagram:jar:5.2.0
- Missing artifact com.aspose:aspose-
words:jar:15.4.0
- Missing artifact com.aspose:aspose-
imaging:jar:2.7.0
- Missing artifact com.aspose:aspose-slides:jar:
15.4.0

Same issue for 2.9.0 java library also
================
Multiple annotations found at this line:
- Missing artifact com.aspose:aspose-email:jar:
5.0.0.0
- Missing artifact com.aspose:aspose-tasks:jar:
8.1.0
- Missing artifact com.aspose:aspose-
words:jar:15.2.0
- Missing artifact com.aspose:aspose-
diagram:jar:5.1.0
- Missing artifact com.aspose:aspose-pdf:jar:
10.0.0
- Missing artifact com.aspose:aspose-slides:jar:
15.1.0
- Missing artifact com.aspose:aspose-cells:jar:
8.3.2

When i tried to resolve this using the above said version artifacts, still the same issue for that dependency.
please let me know how to solve this issue

Thanks & Regards
Vijay

Hello Vijay,

Thank you for using GroupDocs.Viewer for Java.

As we understand you , that you downloaded our full library from our site here. This library should include all these Aspose libraries. We think that the issue may be caused in your local maven repository you have installed our slim library mistakenly. Please try to delete from your locale repository our library and install it again. If this not help you , then try to add these Aspose dependencies to your pom.xml. All these Aspose libraries you can find in our spring sample here .

If all these steps not help you , then please share with us your pom.xml file.

Best regards
Evgen Efimov

http://groupdocs.com
Your Document Collaboration APIs
Follow us on LinkedIn, Twitter, Facebook and Google+

Hi @evgen.efimov,

Thanks for your reply, i have same problem using GroupDocs.Viewer for Java. Can you refresh your spring sample link ? .

If i add my maven repository it works or not ?

Best regards
Eren

@ereener,

Thanks for contacting support.

It is important to inform you that the versions 2.9.0 and 2.11.0 are obsolete now and their support has been discontinued. We have launched the next generation of GroupDocs.Viewer for Java (starting from version 3.0.0). You can download the latest JAR from here or install it in your project using Maven following the guidelines provided here. Hope it helps.