Free Support Forum - groupdocs.com

Is it a compulsory to use Maven and an IDE of any kinds(eclipse- NetBeans- etc) to use Groupdocs.viewer or groupdocs.annotation


#1

Hi, This is Yern Yee.

I would like to ask regarding groupdocs whether it’s a compulsory to use Maven and an IDE of any kinds(eclipse, NetBeans, etc)

to use Groupdocs.viewer or groupdocs.annotation. I am sorry for being a total newbies in Java framework.

I did download and install maven as taught in the sample. I have Apache Maven version 3.3.9.

And when I did mvn test compile on GroupDocs.Viewer_2.14.0-Java-Examples\GroupDocs.Viewer_2.14.0-Java-Examples\samples\spring, it shows

[INFO] --- maven-compiler-plugin:2.3.2:testCompile (default-testCompile) @ groupdocs-viewer-spring ---

[INFO] No sources to compile

I’m really sorry for disturbing and will be very glad if you could reply my email and perhaps guide me a little on how to do it on Java.

Thanks


Regards,

Yern Yee


This message was posted using Email2Forum by atirtahir3.

#2
Hello,

Thank you for your request.

You do not need to use the IDE to run our samples of the library, but we recommend to use them , because you will be able to configure the library and debug it. One of the important points to run the sample is Java web server (Apache Tomcat, JBoss , Wildfly and etc) so your server is suitable. In our demo examples we have attached a readme.md file in which described how to run our examples via run.bat file.


So please follow these instructions and if you will have more questions please feel free to contact us.

-------

Best regards,
Evgen Efimov

http://groupdocs.com
Your Document Collaboration APIs
Follow us on LinkedIn, Twitter, Facebook and Google+