Free Support Forum - groupdocs.com

Javascript error when using IIS server


#1

Hi, I have a problem when using the .NET annotation library, it works perfect when I run under VS IIS express, however, when I run it under local IIS server, I would get a javascript error:

http://localhost/signalr1_1_2/hubs 404 (Not Found)



It seems like under IIS server, the annotation library can not generate the right path for signaler, and then the annotation tool bar would not be displayed properly.



Is there any idea to fix this ? Thanks!


#2

Hello Brian,

We are sorry to hear that you have such issue. It seems that you are using Virtual Directory on your local IIS web-server. Am I right? Please check other correct requests from GroupDocs.Annotation. I guess all other correct requests have URL like http://localhost/your_virtual_catalog/document-viewer… and http://localhost/your_virtual_catalog/document-annotation…

If I’m right, please add a
Groupdocs.Web.Annotation.WidgetFactory.SetBaseUrl(“http://localhost/your_virtual_catalog/”);
to the “Application_Start” method in the Gloval.asax, where GroupDocs.Annotation is initialized.

If you will have more questions please feel free to contact us.


#3

Hi,

Yeah, I was using virtual directory on my local IIS web-server. I’ve tried to add the statement in Global.asax, but it seems not help. I still get the same error.



Attached is my project and screen shot for you to check my error, thanks.

project:https://app.box.com/s/ft11lp5rm29ei3yfgxcy

screen shot: https://app.box.com/s/lzff78fa7ib8kxe7m15k


#4

Hello Brian,

We are sorry to hear that you have such issue. We downloaded, reviewed and investigated your project. You’ve used standard SQL Server database, so we changed connection string for pointing to the SQL Server Compact DB.

Unfortunately we can reproduce the error with IIS Virtual Directory that you have. There is no need for a IIS, IIS Express with Virtual Directory is enough.

Groupdocs.Web.Annotation.WidgetFactory.SetBaseUrl(“http://localhost/Annotation”); really cannot help, and I don’t know what is wrong with that thing. It seems that this is a GroupDocs.Annotation bug or I don’t know something, I will investigate this and will reply you at this thread if I will know something useful.

But there is a trick how to fix this. URL http://localhost/signalr1_1_2/hubs is incorrect, but you can inject correct URL by yourself. Go to the Views/Home/Index.cshtml, and add a

to the HEAD section of the page, right under the place where GroupDocs.Annotation scripts are invoked. This will help.

Sorry for that inconvenience and please notify us if you will have any issues or questions, we will be glad to help you.


#5

Hi,



Thanks for your response. Right now the temp solution could work, but this solution also has a problem, it works if I run on my machine, however, when someone access to my local server and try to annotate through my website, the problem remains. So is there any other solution to this? Thanks!


#6

Hello Brian,

We are very sorry for such long reply. The problem that is discussed here is very strange because I cannot find an exact reason of it.

Now I’m working with the project that you have sent to me, it uses .NET Framework 4.5 and ASP.NET MVC 5. Please try to do the next:
1. Remove “SetBaseUrl” method from the “Application_Start()” method. Leave only “Groupdocs.Web.Annotation.WidgetFactory.Initialize(this.Context,@”~/App_Data");"
2. Remove or comment sections “” and “” in the web.config.
3. Remove “” from the Index.cshtml file.
4. Make full cleaning of the project: remove all GroupDocs.Annotation-content from the database, “file-sessions.json” file, “vs.bin” file, “temp” folder; remove all cookies that are associated with the web-site that you are using.
5. Clean and rebuild the project, run it and see what will happen with SignalR-related requests and annotation toolbar.

If this will not help, please do the following:
1. Download the latest version of GroupDocs.Annotation for .NET ver 1.5, replace the old 1.4 library with this new one and run the project again. If this will not help too, please proceed to the step 2.
2. Once again please upload your test project and provide me a link for one more investigating and reproducing, but with the latest version of GroupDocs.Annotation at this time.

One again, sorry for such long reply and for problems with using GroupDocs.Annotation.