Lib conflict between groupdocs-conversion and groupdocs-viewer

Conversion lib fails when we add viewer lib dependency to the project, this issue only happens in Linux environment and when we run the project on Tomcat Server. It works well when I run the same project on a Windows machine, or when I run the project without the viewer lib dependency but using other libs like groupdocs-annotation or groupdocs-watermark.

I got this issue while I was testing GroupDocs Conversion with Docker, in the attachements you will find the project zip file, this project is the Spring Demo Project that I got on GroupDocs Github, the current revision of the project is bellow, and there is git-log.png and git-status.png to show the status of the Git project:

commit a975cfdecab375e9c5ea4bdcbf488839074e7e18 (HEAD -> master, origin/master, origin/HEAD)
Author: vsevolod.orefin <>
Date:   Thu May 26 10:35:00 2022 +0300

    Repo URL changed to https

The changes that I did to the project were:

  • added the viewer dependency to the pom.xml
  • added a test endpoint to try conversion
  • added docker files to start the containers

There are two docker-compose files, one for the Tomcat test and another for the SpringBoot test, to run them execute the following commands:

  • docker-compose -f docker-compose-springboot.yml up -d
  • docker-compose -f docker-compose-tomcat.yml up -d

Once the server has started you can do a test with the following URL:

  • http://localhost:8181/conversion/test?file=/home/sample.docx

The application will work for the SpringBoot test but it will fail for Tomcat test. In the archive, you will also find log logs.


Host Machine: Windows 11 Pro 21H2 22000.1335
Docker Desktop 4.15.0 (93002)

1 Like


We are investigating this issue. Your investigation ticket ID is CONVERSIONJAVA-1860.