We're sorry GroupDocs doesn't work properply without JavaScript enabled.

Free Support Forum - groupdocs.com

Not able to configure and link Azure storage to Groupdocs on portal

We are not able to find the section where I can configure and link Azure storage to Groupdocs annotation and viewer so that the files can be fetched for display. The base URL of the API call is https://api.groupdocs.com/v2.0
The version of the SDK used is 2.12.164

Hello @Rlester
Could you please specify more detailed what are you trying to do and what SDK do you mean and use ?

Hi Vitaliy,

We are using Groupdocs viewer and annotation tools. The configurations were made to link to Azure storage so the tool can fetch the files from there for display. Now, we are in process of migrating the storage and will need to update the configuration so the tool gets linked with a new instance. I am attaching the image of the SDK’s used and the annotation view for your reference.
We can set up a call for more discussion.
annotation_image.jpg (146.6 KB)
groupdocs_sdk.png (20.7 KB)

@Rlester thanks for clarification we are investigating your request will notify you once we’ll have updates


  1. You can add a new storage at the Dashboard as it shown on the screenshot:

  2. Then you can create a new Application that is going to use the new storage as a default one or update the existing application to use the new storage

  3. In case you created new Application update Client Id and Client Secret in your app that is using SDK

Hi Vitaliy,

We followed the steps you shared but the files did not display in the tool.
After creating the storage and application we received Client Id and Client Secret keys while in our code the method accepts UserId and Private Key.
Are the both same?
groupdocs.png (10.6 KB)


Yes, these keys are the same. They just changed their names.

We were not able to access the groupdocs using the steps mentioned in your previous reply. Can we set up a call next week to resolve this issue?


Could you please confirm that you can’t access the API with the new keys?

Unfortunately, free support does not have a call option. Please share more details about the issue and we’ll try to help you to resolve the issue.

Please let us know how to add paid support to our account. This has been going on for many weeks now and we need to resolve this asap.

Jaspinder Singh
SVP Global Application and Development | Endeavor
+44 (0) 7823 346 135


You can avail paid support here.

We tried again and the document did not load with the new keys.


It seems that you have to use https://apps.groupdocs.com/ to manage your API keys instead of https://dashboard.groupdocs.cloud/. Please try login to https://apps.groupdocs.com/ and navigating to My Account -> Storage section as shown in the screenshot

Please let us know if it worked for you.

Hello @vladimir.litvinchik,

Can you confirm that Azure storage with AccountName rwc2015 is connected with this Groupdocs account only?
And will adding a new azure account overwrite the existing one, as the current account is associated with the live site?


I’m sorry for the delayed response. Unfortunately, I do not have access to the Accounts database. Please contact through https://forum.groupdocs.cloud/ and I believe my colleagues will help you.