Free Support Forum - groupdocs.com

Parse Error when installing Wordpress Plugin


#1

Parse error: syntax error, unexpected T_FUNCTION, expecting ‘)’ in D:\main\baczanss\Portfolio\wordpress\wp-content\plugins\groupdocs-viewer\tree_viewer\lib\groupdocs-php\APIClient.php on line 255


#2

Hi Sbaczanski,

Thank you very much for your interest in GroupDocs.

Could you please provide us additional information about your environment: PHP, OS, WP versions? According to the error looks like you have PHP < 5.3 - our WordPress Viewer plugin requires PHP 5.3 or higher. Please check this and notify us if you need any other help with our plugins.

Kind regards,
Vipin Thomas, GroupDocs Support Team.
http://groupdocs.com


#3

5.2.6


#4

Hi Sbaczanski,

Thank you very much for your interest in GroupDocs and for your time.

Could you please notify us if you managed to resolve the issue with old version of PHP? If you cannot update PHP version to PHP 5.3.x please notify us the reasons for this. Maybe you would like our GD Viewer plugin supports your version of PHP? We can provide you a simplified version of the plugin that doesn't use GD SDK, so it will work with any PHP versions.

Kind regards,
Vipin Thomas, GroupDocs Support Team.
http://groupdocs.com