Free Support Forum - groupdocs.com

Problem running Java example on OS X


#1

Hi, I’m trying to install the spring java example on a Mac OS X.



I downloaded the GroupDocs.Total library and examples. I installed locally the annotation library in the maven repository (size of the annotation jar file: 84661259 bytes).



When I try to run the run.command I get following error from maven:

[ERROR] Failed to execute goal on project groupdocs-annotation-tomcat: Could not resolve dependencies for project com.groupdocs.samples:groupdocs-annotation-tomcat:war:2.0.0: The following artifacts could not be resolved: com.aspose:aspose-cells:jar:8.4.1, com.aspose:aspose-tasks:jar:8.3.0, com.aspose:aspose-words:jar:15.4.0, com.aspose:aspose-slides:jar:15.4.0, com.aspose:aspose-pdf:jar:10.3.0, com.aspose:aspose-email:jar:5.2.0.0, com.aspose:aspose-imaging:jar:2.7.0, com.aspose:aspose-diagram:jar:5.2.0: Failure to find com.aspose:aspose-cells:jar:8.4.1 in https://repo.maven.apache.org/maven2 was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced -> [Help 1]



What can I do?


#2
Hello ,

Thank you for your request .

We have tried to reproduce the same issue on our side , but we can't, the spring sample works well for us . Could you please share with us your Maven version and JDK version and we will recheck our sample with this environment. Also, could you please try to check our pre-release version of the library which you can download from here .

We will wait your details.

---------

Best regards,
Evgen Efimov

http://groupdocs.com
Your Document Collaboration APIs
Follow us on LinkedIn, Twitter, Facebook and Google+


#3

Thanks it worked!


#4

Hi Ptrick,


Glad to hear that and thank you for the notification.

Best regards.