Free Support Forum - groupdocs.com

RTL Lnaguage problem


#1

Hi,


related to the old post
http://groupdocs.com/Community/forums/1/4253/problem-with-some-pdfs-and-poor-performance-in-tiff/showthread.aspx

If found another problem when display RTL documents within the viewer which disables the search capabilities for the document content and the copied test is wrong.
the problem is as follows:
when I try to copy the content of an RTL document [Arabic in particular] the copied text is reversed like in a mirror; for example the word “صخر” when copied for the document content is returned like this “رخص”. even the word itself is correctly displayed in fornt of the user.
Also the search is only working for the latin words but not in RTL even the thew word in fornt of you and you try to search it wont search.

Attached is a sample document that i provided to you last post for localization, if you search for English it will find it, any other words it will not find. and if you try to copy and paste the Arabic content you will find that the letters are reversed.

#2

Hello,


We are sorry to hear that you have such issue. The copying of the RTL word is an known bug and we work on it.

As for RTL text search - it should work if you use “.useRtl(true)” parameter and if you will type search text manually (don’t copy it).

#3

using the property useRtl(true) is not working and i cannot search for Arabic text within any document in the HTML5 mode, not the image mode


is this feature tested.

#4

Hello,


Thank you for the notification. Our product team will check and fix this issue. We will notify you when it’s will be ready.



#5

Hi,


the problem for searching Arabic text “RTL language” still not working properly even the reported bugs before solved.
the scenario as follows:
  1. If I enter the search text manually the search won’t retrieve any results at all.
  2. but If i copied the word form the viewed file then paste it in the search box, then try to search; surprise surprise it highlights the word in the viewed document !!
please explain this behavior to me, why it;s working when copying form the viewed document and not working when the word is entered manually?

I’m using viewer version 2.12.0




#6

Hello Msamir,


We are sorry for that. We have created a bug ticket (which you can check, it’s attached to the first post of the thread). Our product team will resolve it and we will notify you then.

Sorry for the inconvenience.