We're sorry GroupDocs doesn't work properply without JavaScript enabled.

Free Support Forum - groupdocs.com

Slow conversion time on VirtualBox VMs

GroupDocs.Viewer conversion is much slower when running von VirtualBox machines.
I also tried with VMWare and Hyper-V virtual machines and there was only a small (and expected) performance drop from virtualization.
With VirtualBox however it’s 3 to 4 times as slow.
For example the included “K03.10289.101.1_REV4.dwg” takes about 8 seconds to convert locally and 35 seconds on the VM. A docx file for example was 3,6 times slower.

I have prepared a minimal VirtualBox VM with the issue reproducible.


Password for Administrator is “Pa$$w0rd”
On the Desktop there are is a “ViewerSpeedTest” folder with a simple test app. (You can of course test with your own apps, it should not matter)
You can use it to convert the included “K03.10289.101.1_REV4.dwg” file like this:.
GroupDocs Core.png (39.8 KB)
This file was also used in this discussion:

So it should convert way faster than that.
Can you please check why conversion is that much slower on VirtualBox VMs?

@Clemens_Pestuka

Thank you for sharing the VM and your results. We’ll investigate this issue and update you.

1 Like

Hi @Clemens_Pestuka

About performance on VirtualBox VM:

Performance little bit better if:

  • I change chipset to ICH9 in VM settings
  • If I leave HOST OS enough memory to run

I compared .net framework performance and Core performance and it show valuable performance comparison:

DWG file .NET Framework: 13-14 secs .NET CORE: 8-9 secs
DOCX file with 50+ pages: 1141 ms .NET CORE: 221 ms

So it is a reason to move project to .NET CORE.

1 Like

Hi @mikhail.evgrafov.aspose,

Thank you for your analysis :slight_smile:
I wanted to test switching to ICH9 chipset, but I noticed the performance issue was already gone (10 seconds with .NET).
After double checking everything, it turned out that hypervisor caused my performance problem.
I deactivated it for VMWare, but VirtualBox seems to rely on it to some extent.
So this command was fixing the issue for me:

bcdedit /set hypervisorlaunchtype auto

Sorry for the inconvenience, this was not a GroupDocs problem.
We definitely will consider moving to .NET (Core) as it really seems to improve general performance :slight_smile:

3 Likes

@Clemens_Pestuka

No problem.