Viewing / annotating fails on file uploaded via API


#21

Hi @schlueter Sorry for taking so long time - our Product team has resolved the issue and tested it on the stage environment. In the production it will be released in the nearest time.

Best regards


#22

Hi @schlueter We have released a fix for this issue. Please try again and notify us with the results.

Best regards.


#23

Hi Pavel,

thank your very much - yes, it is working, finally! I can open a document uploaded from a HTTP-scource in the viewer and in the annotation-tool!

That said, in the annotation-tool I get a message saying

“Uh-oh, something went wrong!
Error occured while sending request.”

after the content is loaded completely. I don’t´know if this is an serious error, but it will confuse my users, for sure. Maybe you can investigate this issue too, to make it perfect at last?


#24

Hi @schlueter Thank you for coming back. Could you please provide step by step guide for how to reproduce the new issue because I can’t reproduce it - all works well.

Best regards.


#25

The new issue is easy to reproduce: assuming that you are able to log into my account, try to open one of the files in directory ‘online-trainings’ in the annotation-tool - both of them were uploaded via API from web-sources. After loading and displaying the content the error message mentioned above will show.

Maybe the fact that thumbnails are not available in this case can be a hint: when opening the same documents in the viewer instead of the annotation-tool thumbnails exist and the error does not show…


#26

Hi @schlueter When you reported this issue I have checked it exctly in the same way and all works fine - that’s why I’m asked you for the guide for how to reproduce the issue. Could be that the issue reason is in the document that you use- could you please share it.

Best regards.


#27

The issue is definitely not related to the document itself, but - again - to the way it was uploaded / moved to its place. I put an copy of one of those documents called ‘dummy_03.pdf’ into the ‘my web documents’ folder, this time using the upload-function on the dashboard. This version opens without any problem in the annotations-tool - no error displayed and thumbnails presented correctly.


#28

Hi @schlueter
1 I have uploaded the file from Web via API screenshot
2 Moved it and renamed screenshot
3 Opened it in the Annotation screenshot

So I followed your workflow exactly and there is no any issues. I will investigate your account logs for more information.

Best regards.


#29

Thanks for your effort, again.

To be sure that it isn´t a browser-specific error, i tried the procedure in another browser and got the same result: error message and no thumbnails

scrrenshot-chrome.jpg (575.7 KB)

I would be very thankful, if you would have a look at the logs!


#30

Hi @schlueter One more question - the file can be opened in annotation after opening in viewer? Try to open it in the Viewer and then in the annotation, We need to found this out.

Thank you


#31

Unfortunately not. I can open the document flawlessly in the viewer app. When i switch to the annotation app directly and open the very same file, i get the result described / screenshotted above.


#32

Hi @schlueter Thank you for this info. Will return to you shortly.

Best regards.


#33

Hi @schlueter We were able to reproduce the issue - we have created a bug ticket for it. I will return to you when the fix will be released.

Best regards.


#34

I’m looking forward to it!


#35

Hi @schlueter I will keep you updated.

Best regards.


#36

I would like to ask if there is a solution in sight for the latest issue i had?


#37

Hi @schlueter Thank you for your request. Our product team curently work on it and the fix will be availeble soon.

Sorry for the inconvenience.


#38

Hi @schlueter We have released a fix for the issue. Please try again and notify us with the results.

Best regards.


#39

Pavel,
what should I say … nothing changed for me, though I tried in three different browsers. In annotation the freshly uploaded document opens and the contents get displayed. But then, an error message appears and the thumbnail-images are displayed as “?”, saying that the corresponding imagefile could not be loaded.

It seems to me as if an AJAX-request fails. Browser-tool says

POST https://apps.groupdocs.com/Portal/PortalService.svc/ListAnnotations 400 (Bad Request)

Additionally, I loose any annotation I already made in a document when leaving it.


#40

Hi @schlueter I have tested the copy and move API functionality for a several times with this code:

$createFolder = $storageApi->Create($clientId, “on-line”);
$uploadResult = $storageApi->UploadWeb($clientId, “http://www.africau.edu/images/default/sample.pdf”);
$id = $uploadResult->result->id;
$moveFile = $storageApi->MoveFile($clientId, ‘on-line/dummy_03_renamed.pdf’, NULL, $id, NULL);

All works well and can copy rename file and annotate it. Please make sure that you use GroupDocs SDK version 2.6.0 - you can check this in the composer.json file.

Best regards.