Free Support Forum - groupdocs.com

Visio loading half of the file


#1

image.png (12.5 KB)

I tested it with several visio files, and all with the same problem.

i just downloaded the https://github.com/groupdocs-viewer/GroupDocs.Viewer-for-.NET-MVC and dont change .

Exemplo_Vizio.zip (1.6 MB)


#2

@foller,

We have tried rendering your provided Visio files in GroupDocs.Viewer for .NET MVC application and the results are as expected (see screenshot) and we could not spot any issue. Would you please share whether you are using image-based or HTML based rendering? For this, you can check the settings in the configurations.yml file (see this). Furthermore, please share with us the name and version of the browser you are using to run the application.


#3

@usman.aziz

Hello usman, I downloaded the git groupdocs.viwer again, I tested it with image mode, and it worked, I put it back to html and the problem came back.

in relation to the browser, the problem is that it already generates the temp html with problem.

I am sending you the prints and the project.

image.png (10.8 KB)
image.png (38.6 KB)

GroupDocs.Viewer-for-.NET-MVC-master (1).zip (69.0 KB)


#4

@foller,

Thanks for providing the details. Would you please download the following application that only misses the latest commit and check if your Visio files are correctly rendered in the HTML mode?


#5

@usman.aziz

Usman, Same problem.


#6

@foller,

Let’s try one more time after clearing the cache of GroupDocs.Viewer. It might be possible that the API is fetching the rendered files stored in the cache. Please remove the files from DocumentSamples\Viewer\temp folder and then run the application again.


#7

@usman.aziz

Usman, i have tested again, cleared the cache and rebuilding the project. I got the same problem. Could it be something on my machine?


#8

@foller,

We have verified the MVC application on multiple machines but we are unable to reproduce the issue and Visio files are rendering without any problem.

To verify this, please download this sample console application and run it at your end. The input Visio files are located in the Storage folder and the rendering results will also be stored in the same folder (see this). Please check and share if you are getting the same results using this application.


#9

@usman.aziz

Helow Usman, I have tried in another machine, and i have the same problem, de html does not fully render.
only the svg.
image.png (7.2 KB)
image.png (53.5 KB)


#10

@foller,

It is strange that the same application is giving me the correct output, see this. Could you please share with me all the files (HTML files and the resources) that are created in ..\Viewer_ConsoleTester\Storage\Politica_.vsdx\ folder?


#11

Storage.zip (1.3 MB)
Folowws the file


#12

@foller,

In your provided archive, the Storage folder doesn’t contain the subfolder Politica_.vsdx like this. Please clear the viewer’s cache, re-run the console application for Politica.vsdx file and then share with us the files that are created in the following folders:

  • ..\Viewer_ConsoleTester\Storage\cache\Politica_vsdx\
  • ..\Viewer_ConsoleTester\Storage\Politica_.vsdx\