Free Support Forum - groupdocs.com

Work with several parallel requests


#1

Hello Dear GroupDocs team,

Do you have best-practices to organize work with the Viewer when user can start several requests to Viewer without previous finished.

Our scenario:
We have table with a lot of rows. When user changes the row we show him the new document. When user several time changes the row we receive the error below. So users start to switch between rows and do not wait opening of the document:



Our code for opening the document:
Dim helper As Groupdocs.Web.UI.ClientHelper = Groupdocs.Web.UI.Viewer.ClientCode().TargetElementSelector("#test").FilePath(file_name).ShowPrint(False).ShowDownload(False).ShowFolderBrowser(False).ShowImageWidth(False).ShowSearch(False).ShowThumbnails(False).ZoomToFitWidth().ShowViewerStyleControl(False).ShowPaging(False)
Label1.Text = ASPxGridView1.GetRowValues(ASPxGridView1.FocusedRowIndex, “IDN”).ToString()
ScriptManager.RegisterStartupScript(Me, Me.GetType(), “jsCall”, helper.ToString(), False)

Thank you for your help!


#2

Hello,

We are sorry to hear that you have such issue. Unfortunately we cannot reproduce an issue that you had described. We have no best practices how to organize simultaneous work with GroupDocs.Viewer because we never faced with such problems. GroupDocs.Viewer is designed to maintain multiple simultaneous requests well.

We used your project “TEST_OXU” that you shared with us at previous time. We added a bunch of big documents with a lot of pages to the “WebForms1.aspx” page, where DevExpress ASPxGridView is situated on the UpdatePanel along with GroupDocs.Viewer. After intense testing we could not reproduce your issue - all works well while we switched intensively between different loading documents.

From your screenshot we can see that exception occures “inside” Viewer. We need all details of this exception: full stack trace and full content of “Сведения об исключении” error window.

Please come back to us with additional details.


#3

Hello,

Thank you for sharing stack trace. We tried to reproduce the issue and unfortunately your issue is still unreproducible for us. After testing all works fine for us, we tried different ways to reproduce the issue such as changing access rights for the folder with files, deleting file which should be view etc.

We suggest you try to use the latest version 2.1.2 of GroupDocs.Viewer for .NET, which was released as a hot fix http://groupdocs.com/Community/files/8/.net-libraries/groupdocs_viewer_for_.net/entry1629.aspx please download it.

Please try to use this version with your project and come back, if it will not help.



#4

Hello,

We reproduced the main error in test solution (https://mega.co.nz/#!2pByFRZR!OBPiCdF_ypmUY9uUJfWweZa_dg0thSwsuS5f_ERTcpI). When we try quickly click several rows the following error appear:



#5

Hello Dear GroupDocs team,

Do you have some news about our issue? Do you need any additional clarification from our team?

Thank you for your help!


#6

Hello,


We are sorry for such long delay. The issue that we faced here is not easy to reproduce.

DevExpress components that you are using are expired for us, so we had to rewrite your code in order to replace it with another approach. Finally, we are able to reproduce the bug that you described and depicted. It occurs only in Internet Explorer, we couldn’t reproduce it with other browsers.

This is bug inside GroupDocs.Viewer, developers are aware and started to work with it. So stay tuned and please accept my apologies.

If you will have more questions please feel free to contact us.


#7

Hello,

Thank you for the answer and your investigation. The Internet Explorer is corporate standard for us, so we can not migrate on another browser.

Can you, please, estimate when this bug can be solved?



#8

Hello,

Our developers worked with this bug yesterday and today and now it has been fixed. Now, we will send a mail message to your email address (at gmail.com) with link to the latest GroupDocs.Viewer version. Please clear cache in the Internet Explorer before using this new version (Tools->Delete Browsing History -> Temporary Internet Files).

If you will have more questions please feel free to contact us.


#9

Hello!

Thank you a lot for your help! We will check the new version asap!



#10

Hello,

Test version works fine. Can we use it, or we need to wait official version?


#11

This request was replied trough Banckle Live Chat.