Free Support Forum - groupdocs.com

Document view layout errors


#1

Hi,

we have a problem with this html document while viewing it with html engine set to true. Try opening with the viewer and with a browser. The error is due to the css selector
.grpdx .ie .doc-page .html_page_contents > div

This is a very often used file by our customer due to new italian laws and need to view it in the correct way asap…
Thanks
Gianluca

#2

Hello Gianluca,


We are sorry to hear that you have such issue. We have reproduced it and we created a bug ticket. Our product team works on resolving and we will do all our best to come back to you with the solution ASAP.

Sorry for the inconvenience.

#3

That’s ok but we need , within the next release to be resolved the other IE versions bugs. If it’s not the case, we will not can use the new dll!


#4

Hello Gianluca,


Just to notify you that the resolving of the issue with the HTML file will take few days. When it will be ready we will notify you.

Also as for the issue with the “quircks” document mode - We strongly recommend you to not use this mode because of next: This mode isn’t a default mode of the browser and all JS issues of your project which you doesn’t see in this mode (as I understand you from other thread you use this mode because in the standard mode you have errors in the browser console) will have final user of your web site - he will see all of them because, as I said, browser uses different default document mode which is “IE9 Standards” or in case using IE 11 “Edge”. Since that we strongly recommend you to fix your issues and use standard document mode. Believe me it will save you a lot of time later when you will have requests from your users that they all have tons of errors because of using default browser mode.

If after all these you will decide to use quirks mode - try to add such including on the iframe web page and Viewer web page:

It will add Json2 library in to the web page.

Best regards.

#5

Hi Pavel,

this bad browser mode is used for site architectural reasons, because by now we can’t change all this architecture to switch to normal document mode i’m sorry that we can’t avoid the use of quirks mode. I tried with the js inclusion but this doesn’t do the trick…

Thanks

Gianluca

#6

Hi,

founded another rendering problem with this pdf. Try out with latest version.. Thanks,

Gianluca


#7

Hello Gianluca,


Could you please explain what is wrong with this document? We have tried it and it’s rendered wel in the IE9 and other browsers.

Thank you.

#8

Hi Pavel, i saw that going to the end and after returning by scroll to upper pages, thoses as shown as blank pages.


Please, try out with this new docx file, it freeze the browser and after cause a lot of js errors.

Thanks

Gianluca

#9

Hello Gianluca,


We checked this new document, and all looks fine even in quircks mode. Since that could you please describe full list of your software that you use for the web project with Viewer and all settings and configs of the IIS, browser and internet that you use.

Thank you

#10

What version of viewer are you using for tests?


Gianluca

#11

Hello Gianluca,


For testing we use the same version which we shared with you with the latest fix. Maybe you should try to download it again and clean/rebuild your project again just in case - could be your project still uses previous version (cached some where in the IIS or VS).

Best regards.

#12

Hi,

all caches was empty before restarting tests. in IE9:
By now try thoses. I see that there is the zoom/cut document bug that was resolved some release ago but now still present.
In our web site we use telerik controls and for internet options which section do you prefer to see?

Gianluca

#13

Note that now, in production, we are using 2.10 version for asp.net MVC project and 2.11.1 for asp.net one.

For tests of previous post i used latest 26/6 version linked in your post
Gianluca

#14

Hi Gianluca,


Could you please also (if possible) share with us full version of your project (with telerik controls, all styles and so on) that we can check it and found out how to resolve these issues because when we test with example project that you shared with us earlier (“IFrameViewer”) we can’t reproduce these issues.

Thank you.

#15

I’m sorry but we can’t share source code of our application, if you want you can try our app in a teamviewer session!


Gianluca

#16

Another important bug… Trying the latest version of library , opening a xls it give error


Impossible to load type ‘Aspose.Cells.CollectionBase`1’ from assembly 'Aspose.Cells, Version=8.3.1.3, Culture=neutral, PublicKeyToken=716fcc553a201e56’

in .MVC project. With all xls files.

Gianluca

#17

Hi,

is there any news?
Thanks
Gianluca

#18

Hello Gianluca,


Sorry for the delay. We have checked issue with xls file (we used your Boors1.xls) and we can’t reproduce it, all works fine for us with the lates Viewer and MVC project. Please make sure that you add " Viewer.InitRoutes();" in the Globals and

in the web.config.

Also does this error acquires with all xls documents, if not please share failed document.

As for the other issues - unfortunately currently I don’t have any news for you, our product team still works on them. I expect to receive new information tomorrow.

Sorry for the inconvenience.

#19

Hello Gianluca,


Could you please if possible share with us public URL of your application that we can check it head sections or share with us full HTML code of the head section of the web page with the Viewer iframe (just in case - right click on the web page in browser and select view page source).

Thank you

#20

Sorry but there isn’t a public url, our site is a local web application for local intranet. Maybe a teamviewer session could be a solution?