We're sorry GroupDocs doesn't work properply without JavaScript enabled.

Free Support Forum - groupdocs.com

Error on PDF Viewer

we are getting Error Like

  1. Sequence contains no matching element
  2. Exception of type ‘System.OutOfMemoryException’ was thrown
  3. [Unlicensed version of GroupDocs.Viewer for .NET allows 15 views per one hour] …after Renewal

1.png (28.7 KB)
2.jpg (150.5 KB)
3.png (27.3 KB)

Please help ,its urgent

@ithead

Have you managed to replace the old license with the new one on the server where your application is running?

Yes replaced license also delete and Add new license not working

@ithead

Have you tried to restart the application? Please attach the new license, and share which version of the GroupDocs.Viewer you’re using.

YEs tried with Restart Application and Server as well .

Version attached in screenshot

image.png (17.2 KB)

@ithead

To reproduce the issue on our side I need the license file with *.lic extension and the version of GroupDocs.Viewer.dll that you are using.

GroupDocs.Viewer.NET.zip (745 Bytes)

@ithead

Thank you, I would also need the version of GroupDocs.Viewer.dll. In case you cant determine the version of the assembly please upload it to some cloud storage and share the file with us.

GroupDocs.Viewer.dll - 18.3

Please reply…its urgent.

@ithead

I’ve reproduced this issue on my side. It could be an issue with the license file. Will update you when I have any new information.

Great , Thank you very much ,

Please provide as soon as possible , my customer facing problem from last 15 -20 days

@ithead

We’ve found that the issue is related to the license verification code in GroupDocs.Viewer. We’re looking for a proper solution. Can you please also attach the license you used before you purchased the new one?

GroupDocs.Viewer.NET.zip (778 Bytes)

@ithead

Thank you for attaching the license file. Your license is valid and can be used with GroupDocs.Viewer for .NET 18.3.

<SubscriptionExpiry>20211210</SubscriptionExpiry>

The subscription expiration means that you can update GroupDocs.Viewer that was released till this date.

Can you try using your previous license file, cleanup cache, restart the application, and open some file?

image.png (110.0 KB)
After modifying Version to 18.3 and license replaced with old license still getting the error.

@ithead

Have you removed the cache? Please also try removing vs.bin file in your cache folder.

image.png (129.9 KB)

yes , i have followed the suggestion but still getting above error.

@ithead

For further investigation please share:

  • the application or a sample application that can be used to reproduce the issue. As an example I’ve been using this sample-app.zip (114.8 KB) to reproduce the issue

  • information about hosting environment OS and its version

image.png (269.1 KB)

seems its working after deleting cache files but another issue comes up i.e. I am trying to view file with 32 pages but only can see 2 pages with Evaluation Only water mark. Please check the attchament.