Free Support Forum - groupdocs.com

"Evaluation Only" message for Full License

We have a customer using GroupDocs.Viewer who is getting the following message after viewing the first two pages of a Word document:

“Evaluation Only. Created with Aspose.Words. Copyright 2003-2017 Aspose Pty Ltd”

This is a paid subscription of GroupDocs, not an evaluation license.

Please advise.
thanks

@Colbourne_Rupert,

Thanks for using GroupDocs.Viewer and sharing your issue with us.

You are getting this message because the API is not working in the licensed mode. The following are the possibilities that may cause this issue.

  • You are not applying the license before rendering the document.
  • You are applying the license but the path to the license file in your application is not correct.
  • Path to license file is correct but the application does not have the rights to access the file.
  • Your license is expired.

Please verify the above-mentioned scenarios at your end and check if the issue is resolved. In case you have enabled the cache, please make sure to remove all the cached files before running the application again. If the issue persists, please share with us the platform (.NET or Java) and version of the GroupDocs.Viewer you are using. Also, please share with us the license file in a private message (see how to send a private message) so that we can investigate the issue at our end.

hi there

We tried these steps - see comments next to them…

• You are not applying the license before rendering the document. - Checked - we do this on application startup, way before viewing a document
• You are applying the license but the path to the license file in your application is not correct. - Checked - not the issue
• Path to license file is correct but the application does not have the rights to access the file. - Checked - not the issue
• Your license is expired. - If this was true we’d have the problem everywhere / new licence didn’t fix the issue

Please can you advise on what next.

thanks.

@Colbourne_Rupert,

Thanks for coming back to us.

In that case, please share with us the platform (.NET or Java) and version of the GroupDocs.Viewer you are using. Also, please share with us the license file in a private message (see how to send a private message) so that we can investigate the issue at our end.

We have similar kind of problem that with production license there is evaluation only mark in the converted documents. We have checked the similar bullets as mentioned in the earlier message:

  • You are not applying the license before rendering the document.
  • You are applying the license but the path to the license file in your application is not correct.
  • Path to license file is correct but the application does not have the rights to access the file.
  • Your license is expired

We are using .net platform.

@PiK,

Thanks for sharing your issue with us.

To avoid any confusion, we have created a separate topic to address your issue. Please follow the following topic for further updates.

@Colbourne_Rupert,

Thanks for sharing with us the required details via private message.

It seems that FIPS is enabled in your machine’s settings which is stopping GroupDocs.Viewer to apply the license as GroupDocs.Viewer uses cryptographical algorithms which are not FIPS-compliant.

To make sure that FIPS is enabled you can:

  • Check the registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\fipsalgorithmpolicy and value should be set to 1.
  • Check Local Security Policy: “Start -> Run -> secpol.msc” and then go to “Security Settings -> Local Policies -> Security Options”. On the right side find “System cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing” policy and it should be enabled.

Resolution: You can choose one of following solutions to fix this issue:

1. In case you don’t need FIPS, disable it from the registry (change value from 1 to 0) or change mentioned Local Security Policy from enabled to disabled (see screenshot).

2. If you want to disable FIPS for a single application (not for ASP.NET applications), disable FIPS with application’s config setting by adding enforceFIPSPolicy setting to your app.config file as shown below:

<runtime>
  <enforceFIPSPolicy enabled = "false" />
</runtime>

3. If you want to disable FIPS for ASP.NET applications hosted on IIS, you can do it by using separate Application Pool with the specific config file. You can do it by following below steps:

  1. Create Application Pool with name DisableFipsAppPool.
  2. Update your application to use DisableFipsAppPool Application Pool.
  3. Create config file e.g. “c:\inetpub\config\disable_fips_web.config” with following content.
<configuration>
   <runtime>
      <enforceFIPSPolicy enabled="false" />
   </runtime>
</configuration>
  1. Grant read permissions to the App Pool (following command is one of the possible ways to do it).
icacls c:\inetpub\config\disable_fips_web.config /grant "IIS APPPOOL\DisableFipsAppPool":(R)
  1. Configure the App Pool to load created config file.
%windir%\System32\inetsrv\appcmd.exe set config  -section:system.applicationHost/applicationPools /[name='DisableFipsAppPool'].CLRConfigFile:"c:\inetpub\config\disable_fips_web.config"  /commit:apphost
  1. Restart IIS.
iisreset

NOTE: All commands should be executed as Administrator.

Please try and share your feedback with us.

Hi,

Thanks for you information. We actualle had wrong kind of license, and now everything is fine.

Best Regards,
Pia

@PiK,

Thanks for your response.

It is good to know that your issue is resolved now.